О программе

Navigation: »No topics above this level«

О программе

 Return to chapter overview

Центр обновлений - SetupSrv.

© ООО Кейсистемс, 2021. Все права защищищены.

Кейсистемс

Телефон: (8352) 323-323, 572757

Web: www.keysystems.ru

Email: budget@keysystems.ru


1. Установка

1. Установка

Для установки программы необходимо скопировать на локальный диск файл установщик SetupSrvI.exe. При запуске файла SetupSrvI.exe отобразится окно с опциями установки (рис. 1):

Рис. 1. Окно приветствия установщика приложения SetupSrv.

Предоставляется возможность установить программу или запустить без установки:

· При выборе пункта «Установить»: программа устанавливается на компьютере, подготавливается к работе и создаются ярлыки для запуска. После установки ее можно многократно использовать для установки любых доступных обновлений.
· При выборе пункта «Запустить»: программа распаковывается во временную папку, запускается и автоматически удаляется после закрытия. Для последующего использования программы установки обновлений необходимо будет опять запускать установщик.
· При выборе пункта «Восстановить»: будет запущена процедура восстановления программы - переустановка всех компонент по ранее указанному установочному пути. Доступно если программа была установлена на данный компьютер ранее.
· При выборе пункта «Удалить»: будет запущена процедура удаление программы - удаление всех компонент по ранее указанному установочному пути с возможностью удаления рабочей директории. Доступно если программа была установлена на данный компьютер ранее.

Для продолжения установки необходимо нажать кнопку «Далее >».

Рис. 2. Окно настроек установщика приложения SetupSrv

Если была выбрана опция «Установить», будет предоставлена возможность выбора путей установки приложения и его рабочей директории, а также создание ярлыков (рис. 2).

Рекомендация: В операционных системах MS Windows 7, MS Windows 8, MS Windows Server 2008 и выше не рекомендуется указание рабочей папки в стандартных системных каталогах «Program Files» из-за возможных проблем с системой контроля учетных записей (UAC) при обновлении программы и файлов обновлений.

Для продолжения установки необходимо нажать кнопку «Далее >».

Рис. 3. Окно выполнения установки приложения SetupSrv

Программа начнет установку приложения - копирование модулей программы по указанному пути (рис. 3).

Рис. 4. Окно завершения установки приложения SetupSrv

Возможен запуск приложения по завершению установки: для этого установите галочку напротив «Запустить ‘Центр обновления баз данных’ после установки» и нажмите кнопку «Готово» (рис. 4). При этом будет произведен запуск приложения SetupSrv.


2. Запуск приложения

2. Запуск приложения

Варианты запуска приложения после установки:

1) Двойной щелчок по ярлыку SetupSrv на рабочем столе.
2) Щелчок по ярлыку SetupSrv в меню пуск «Пуск/Программы/Keysystems/SetupSrv».
3) Перейти в корневую директорию установки и двойным щелчком кликнуть по файлу SetupSrv.exe.

Варианты запуска приложения без установки:

1) Двойной щелчок по фалу установщика приложения SetupSrvI.exe. В открывшемся окне выбрать опцию «Запустить» и нажать кнопку «Далее» (рис. 5). Дождаться запуска приложения SetupSrv.

Рис. 5. Вариант запуска приложения SetupSrv без установки.


3. Настройка приложения

3. Настройка приложения

3.1. Режимы

Приложение работает с локальными обновлениями в автономном режиме («Offline») и с обновлениями расположенными на сервисе обновлений в режиме «Online».

«Online» режим:

· Для работы требуется подключение к сервису обновлений (Internet)
· Для обновления доступны все возможные пакеты обновлений с последними изменениями

Автономный «Offline» режим:

· Для работы не требуется подключения к сервису обновлений
· Для обновления доступны только загруженные пакеты обновлений в их состоянии на время загрузки

При запуске программа пытается перейти в режим «Online» автоматически. При этом происходит попытка подключения к сервису (рис. 1).

Рис. 1. Попытка подключения к сервису обновлений.

Если подключиться не удалось, будет предложено повторить попытку подключения или перейти в автономный режим (рис. 2).

Рис. 2. Подключение к сервису обновлений не установлен.

Переход в автономный режим (рис. 3) будет означать, что программа будет работать с обновлениями, расположенными локально – в рабочей папке программы.

Рис. 3. Главное окно программы – автономный режим.

Определить в каком режиме находится программа, а также изменить режим, можно с помощью кнопки-индикатора соединения с сервисом обновлений, который расположен в левом верхнем углу главного окна программы.

Если в автономном режиме нажать на кнопку-индикатор, то будет произведена попытка перейти в режим «Online».

При успешном подключении к сервису обновлений, кнопка-индикатор изменит свой вид (рис. 4). Также будет отображена информация о текущем подключении: адрес сервиса обновлений и текущее время системы, на которой установлен сервис обновлений (рис. 4).

Рис. 4. Главное окно программы – «Online» режим.

3.2. Настройки подключения

Для настройки подключения к сервису нужно нажать на кнопку-шестеренку, которая расположена в левом верхнем углу главного окна программы, справа от кнопки-индикатора подключения, при этом откроется окно настроек подключения к сервису (рис. 5).

Рис. 5. Окно настроек подключения к сервису обновлений.

Если рабочая машина подключена к сети интернет через прокси, то для успешного подключения к сервису обновлений необходимо указать настройки прокси в окне настроек подключения к сервису (рис. 6).

Рис. 6. Настройка прокси.

Для добавления адреса подключения к сервсиу в окне настроек подключения заполните поле "Адрес сервиса" (рис. 7), выберите порт (по умолчанию 80 и 443) и нажмите кнопку добавить, при этом указанный адрес попадет в список адресов для подключения (рис. 6).

Рис. 7. Добавление адреса подключения.

Для задания приоритетного адреса подключения, в списке адресов сервисов установите галочку "Адрес по умолчанию" напротив необходимого адреса (рис. 8). При этом, при подключении программы к сервису обновлений первым будет использован "Адрес по умолчанию".

Рис. 8. Задание приоритета конкретному адресу.

Если установить галочку "Обновлять адреса при подключении", при следующем подключении к сервису обновлений, текущий список адресов будет удален и заменен актуальным для данного сервиса списком адресов сервисов.

3.3. Автоматическое обновление

В программе реализована возможность автоматического обновления модулей с сервиса обновлений. Если программа успешно соединилась с сервисом и определила, что версия программы устарела, будет предложено обновить программу или перейти в автономный режим (рис. 9).

Рис. 9. Обновление программы SetupSrv.

Работа в «online»-режиме требует наличия у клиента последней версии модулей центра обновления.


4. Обновление БД

4. Обновление БД

4.1. Подключение к серверу БД

Рис. 2. Главное окно программы – Обновление БД

Для начала работы нужно указать поставщика СУБД, адрес или имя сервера, при необходимости экземпляр сервера или порт, имя пользователя и пароль и нажать кнопку «Подключиться» (рис. 3). Для Microsoft Sql Server есть возможность подключиться используя Windows авторизацию, для этого нужно установить галочку "Windows NTLM".

Рис. 3. Главное окно программы – подключение к серверу БД

Если приложение или обновление БД завершилось с ошибкой то при следующем запуске будет предложено отправить лог разработчику. Указанная пользователем информация будет приложена к отчету об ошибках обновления. Заполнение поля с контактной информацией обязательно, т.к. в случае ошибки разработчикам необходимо найти решение проблемы и сообщить об этом пользователю. Достаточно указать электронную почту (Рис. 4).

Рис. 4. Контактная информация.

Указанная пользователем контактная информация (рис. 4) будет отправлена на сервис в случае ошибки выполнения пакетов программы в online-режиме.

4.2. Диалог создания задач

Как только будет установлено соединение с СУБД, автоматически будет выполнен переход на операцию «Обновить базу данных» (рис. 5). Операция «Загрузитьобновления» может понадобиться для загрузки пакетов обновлений без установки).

Рис. 5. Главное окно программы после подключения к СУБД

Если соединение с СУБД установлено и режим работы автономный, то будут доступны две операции: Обновить базу данных и Создать новоую базу данных, причем доступны будут только те пакеты обновлений, которые уже загружены. Для «online» режима дополнительно будет доступна операция загрузка обновлений. В зависимости от выбранной операции откроются дополнительные настройки установки, располагающиеся справа от группы выбора операции.

В списке «База данных» отобразятся доступные базы данных или названия комплексов (рис. 5). Здесь необходимо выбрать обновляемую базу данных или комплекс, БД которого необходимо установить. Над окном со списком баз данных располагается фильтр. Фильтрация производится по названию БД или комплекса (рис. 6).

Рис. 6. Фильтрация списка БД.

При выборе базы данных или комплекса, в зависимости от выбранного типа пакетов, в списке «Пакеты» отобразится список установочных пакетов или пакетов «обновлений/патчей/дополнений» для выбранной базы данных или комплекса (рис. 7).

Пакеты, отображаемые красным цветом – заблокированы по причине ошибки и не могут быть использованы.

Рис. 7. Окно со списком пакетов обновлений.

Над окном со списком пакетов, расположен фильтр. Фильтрация производиться по имени версии пакета. Попадающие в фильтр пакеты будет помечены желтым цветом.

Информацию о пакете можно посмотреть, нажав на кнопку слева от имени пакета (рис. 8). Кнопка появляется при наведении курсора мышки на название пакета.

Рис. 8. Просмотр описания пакета.

В списке «Пакеты обновлений» необходимо отметить установочный пакет и/или пакеты обновлений, которые нужно установить. Пакеты обновлений зависят друг от друга, например, невозможно установить пакет версии 11.01.02, не установив пакет версии 11.01.01.

Если выбрана операция «Установка обновлений», справа от окошка операций отобразятся дополнительные настройки (рис . 9)

Рис. 9. Настройки операции установки обновления на базу данных (настройка резервного копирования).

При установке галочки «Резервное копирование базы данных по указанному пути» (рис. 9) автоматически заполнится поле «Имя резервной копии», содержимое которого можно поменять, нажав на кнопку «…» справа от поля, при этом откроется окно с файловой системой сервера (рис. 10). Установленная галочка означает, что перед установкой первого обновления будет создана резервная копия базы данных с указанным в поле «Имя резервной копии» именем.

При установке галочки «Резервное копирование базы данных после каждого обновления» (рис. 9) означает, что перед выполнением каждого пакета обновления будет создана резервная копия БД с указанным именем. Данная возможность может пригодиться при установке большого количества обновлений: если одно из обновлений завершится с ошибкой, то можно будет вернуть базу к копии сделанной после установки предыдущего пакета обновлений и после решения проблемы с установкой, устанавливать пакеты не с начала, а с версии, на установке которой произошла ошибка.

Установка галочки «Удалить резервную копию при успешном обновлении» (рис. 9) означает, что после успешного выполнения всех пакетов обновлений файл резервной копии БД созданный в процессе обновления, будет удален с сервера, так же файл будет удален после успешного восстановления БД из резервной копии если обновление завершилось ошибкой, и пользователь нажал кнопку "Восстановить".

Рис. 10. Окно указания пути и имени файла резервной копии.

После выбора необходимых пакетов нажать кнопку «Выполнить» (при этом в список текущих задач добавится указанная задача и начнется выполнение), или «Добавить» для составления списка задач (рис. 11).

Рис. 11. Список текущих задач.

Для удаления текущей задачи необходимо выбрать задачу в списке «Текущие задачи» и нажать кнопку «Удалить» или клавишу «Delete».

Для запуска установки пакетов обновлений необходимо нажать кнопку «Выполнить». При этом будет автоматически выполнен переход на вкладку «Выполнение» (рис. 12) и все выбранные задачи начнут параллельно выполняться.

Выполнение обновления можно отменить. Для этого необходимо отметить галочками необходимые задачи, а затем нажать кнопку «Отмена». Также можно приостановить установку нажатием кнопки «Пауза» для необходимой задачи.

Рис. 12. Главное окно программы на вкладке выполнения указанных задач.

В процессе выполнения могут появляться сообщения требующие участие пользователя для разрешения возникших вопросов (рис. 13).

Рис. 13. Пример сообщения, которое может возникнуть во время выполнения.

Выполнение задач может завершиться ошибкой (рис. 14). Для просмотра ошибки необходимо кликнуть по статусному столбцу напротив названия необходимой задачи, при этом откроется окно с текстом ошибки (рис. 15). При возникновении ошибки обновления в режиме работы «online», будет предложено отправить лог установки разработчикам (рис. 16).

Рис. 14. Завершение задач с ошибками.

Рис. 15. Пример ошибки.

Рис. 16. Подтверждение отправки данных.

Если задача завершилась с ошибкой, но было сделано резервное копирование базы, то будет предложено восстановление базы данных и справа от названия задачи разблокируется кнопка «Восстановить» (рис. 14). Если во время выполнения было сделано несколько резервных копий, то будет предложено выбрать файл резервной копии.

По завершении выполнения всех задач, есть возможность продолжить работу с программой, для этого необходимо кликнуть по кнопке «Ок» в правом нижнем углу главного окна (рис. 14).

Кнопка «Открыть папку профиля», расположенная в левом верхнем углу главного окна программы, предназначена для открытия рабочей директории программы. В данной папке находится лог установки обновлений и файлы пакетов обновлений.

При выборе пакета обновления производится проверка наличия подключений к обновляемой БД. Если будут обнаружены клиентские подключения, появится окно предупреждающее о наличии таковых (рис. 17). При этом появится возможность посмотреть на существующие подключения (рис. 18).

Рис. 17. Окно предупреждения о работающих клиентах.

Рис. 18. Список клиентских подключений к БД.


5. Миграция БД

5. Миграция БД

5.1. Подключение к серверу БД

Рис. 1. Главное окно программы – Миграция БД

Для начала работы нужно подключиться к СУБД на которой находится БД для миграции: указать поставщика СУБД, адрес или имя сервера, при необходимости экземпляр сервера или порт, имя пользователя и пароль и нажать кнопку «Подключиться» (рис. 2). Для Microsoft Sql Server есть возможность подключиться используя Windows авторизацию, для этого нужно установить галочку "Windows NTLM".

Рис. 2. Главное окно программы – Миграция БД

Далее в появившемся списке баз данных необходимо выбрать БД для миграции (Рис. 3).

Рис. 3. Главное окно программы – Миграция БД

Если выбранная версия БД не подходит для миграции будет показано предупреждение (Рис. 4). В таком случае необходимо обновиться до подходящей для миграции версии.

Рис. 4. Постмиграционный пакет не существует для данной версии БД.

Если выбранная версия БД подходит для миграции но нет лицензии на миграцию, будет показано предупреждение (Рис. 5). При этом откроется окно для ввода нового ключа (Рис. 6). Чтобы получить ключ миграции необходимо копировать сигнатуру БД и заказать ключ на портале.

Рис. 5. Необходимо получить ключ миграции.

Рис. 6. Сигнатура.

После ввода и применения ключа откроется сообщение об успешной установке ключа [image] далее автоматически заполнятся поля настройки БД приемника (Рис. 7). "Папка выгрузки" и "Резервная копия" относятся к машине СУБД источника. "Папка выгрузки" - директория с временными файлами выгрузки, размер должен превышать размер БД в 2 раза. "Резервная копия" - файл резервной копии БД источника перед выполнением миграции.

Рис. 7. Ключ успешно установлен.

Далее необходимо ввести данные подключения и авторизации к СУБД приемника и нажать кнопку "Выполнить" (Рис. 8) При этом будет произведена попытка подключения к СУБД приемника и создание БД приемника, далее начнется выгрузка данных (Рис. 8).

Рис. 8. Выполнение миграции.


6. Управление

6. Управление

6.1. Подключение к серверу

Рис. 1. Главное окно программы – Управление сервером

Для начала работы нужно подключиться к серверу: указать адрес или имя сервера, порт сервера (по умолчанию 22), имя пользователя и пароль и нажать кнопку «Подключиться» (рис. 2). Подключение происходит по протоколу SSH.

Необходимо авторизоваться под root или другим пользователем входящем в список sudoers.

Так же есть возможноть работы без подключения к серверу, если есть необходимость загрузить контейнеры на локальный компьютер для дальнейшего использования в offline режиме.

Рис. 2. Главное окно программы – ввод данных аутентификации

После успешного подключения можно приступать к установке контейнеров. Установка производится в два этапа:

1. Загрузка контейнера
2. Установка экземпляра контейнера

6.2. Загрузка контейнера

В поле "Контейнеры" видим дерево с названиями контейнеров. Для загрузки на локальный компьютер и сервер, необходимо нажать соответствующую иконку напротив названия контейнера (Рис. 3).

Рис. 3. Главное окно программы – успешное подключение

Состояние загрузки будет отображено в текстовом "статусе", а так же будет дублироваться на заднем фоне контейнера (Рис. 4).

Рис. 4. Главное окно программы – процесс загрузки контейнера

Если контейнер успешно загружен, его название станет выделено черным цветом и все 3 полоски слева от названия станут зелеными, что означает присутствие контейнера на сервисе, пк пользователя и сервере.

В терминале появятся выполненные команды экспорта файлов и распаковки архива контейнера (Рис. 5).

Рис. 5. Главное окно программы – успешная загрузка контейнера

6.3. Установка экземпляра контейнера

Для установки экземпляра контейнера необходимо перетащить активный контейнер из дерева контейнеров в область "сервера" - прямоугольник с заголовком ip:port. При этом всплывет окно подтверждения установки (Рис. 6)

Рис. 6. Подтверждение

Существует зависимость контейнеров друг от друга, так например на сервер можно установить Докер или TaskScheduler. В докер можно установить СУБД-КС или WEB-Сервер-КС, зависимости отражены слева в дереве контейнеров.

В процессе установки в терминале можно видеть лог установки контейнера (Рис. 7).

Рис. 7. Процесс установки

После успешной установки справа в окне "сервера" можно увидеть экземпляры установленных контейнеров (Рис. 8).

Рис. 8. Успешная установка Докер

6.4. Работа с экземпляром контейнера

При успешной установке экземпляра контейнера в окне экземпляра появится тулбар с функциональными кнопками, такими как остановка, удаление, получение информации о контейнере (Рис. 9).

Для работы с сервером так же можно использовать терминал. Не рекомендуется использовать приложения использующие символы отрисовки такие как mc, vim и т.п.


7. Примеры работы

7. Примеры работы

Ниже представлены примеры составления разных типов задач

1. Обновление БД
2. Установка новой базы
3. Загрузка обновлений
4. Отложенный запуск
5. Миграция
6. Управление


1. Обновление БД

Navigation: 7. Примеры работы >

1. Обновление БД

 Return to chapter overview
1. Выбрать в списке "База данных" необходимую БД, дождаться загрузки списка "Пакеты Обновления"
2. Выбрать необходимые пакеты обновлений, при необходимости настроить резервное копирование
3. Кликнуть по кнопке "Выполнить" или, если есть необходимость выполнить обновление нескольких баз, нажать кнопку "Добавить" чтобы добавить текущую задачу в список задач и начать составлять следующую задачу

Рис. 1. Обновление БД.


2. Установка новой БД

Navigation: 7. Примеры работы >

2. Установка новой БД

 Return to chapter overview
1. Выбрать операцию "Установка новой базы"
2. Выбрать необходимый комплекс
3. Выбрать необходимые пакеты (Синим будет обозначен установочный пакет. Есть возможность установить и сразу обновить БД, для это выберите пакет той версии, до которой хотите обновить устанавливаемую БД)
4. Укажите имя новой БД
5. При необходимости укажите пути к файлам новой БД (рис. 2)
6. Кликнуть по кнопке "Выполнить" или, если есть необходимость выполнить обновление нескольких баз, нажать кнопку "Добавить" чтобы добавить текущую задачу в список задач и начать составлять следующую задачу

Рис. 1. Установка новой БД.

Рис. 2. Указываем путь до файлов новой БД.


3. Загрузка обновлений

Navigation: 7. Примеры работы >

3. Загрузка обновлений

 Return to chapter overview
1. Выбрать операцию "Загрузка обновлений"
2. Выбрать необходимые пакеты обновлений (можно использовать кнопку в виде галочки и фильтр пакетов для быстрого выделения или отбора множества пакетов)
3. Кликнуть по кнопке "Выполнить" или, если есть необходимость выполнить обновление нескольких баз, нажать кнопку "Добавить" чтобы добавить текущую задачу в список задач и начать составлять следующую задачу

Рис. 1. Загрузка обновлений.


4. Отложенный запуск

Navigation: 7. Примеры работы >

4. Отложенный запуск

 Return to chapter overview
1. Составить задачи на выполнение (рис. 1)
2. Для вызова диалога настройки отложенного запуска нажать кнопку в виде часов слева от кнопки "Выполнить" (рис. 1).
3. В диалоговом окне отложенного запуска, установить галочку "Включить отложенный запуск". Выбрать дату и время отложенного запуска и нажать кнопку принять, при этом цвет кнопки, вызывающий окно отложенного запуска изменится (рис. 2). Если указанная дата будет меньше текущей даты, остановка задач на ожидание выполнено не будет.
4. Нажать кнопку "Выполнить", при этом выполнятся загрузка установочных файлов, скрипты условий, которые могут вызывать диалоговые окна с вопросами во время выполнения, далее каждая задача перейдет в режим ожидания. Время до запуска будет указано напротив каждой задачи на вкладке "Выполнение задач" (рис. 3).

Рис. 1. Готовые для выполнения задачи.

Рис. 2. Настройки отложенного запуска.

Рис. 3. Ожидание отложенного запуска.


5. Миграция

Navigation: 7. Примеры работы >

5. Миграция

 Return to chapter overview

Миграция из MSSQL в PostgreSQL

Подготовка к миграции.

Перед выполнением миграции необходимо выполнить подготовку к миграции через пункт контекстного меню Подготовка к миграции на базе данных в дереве Управления базами данных. (Сервис - Управление базами данных).

В случае, если в БД отсутствуют необходимые ХП для подготовки к миграции на экран будет выведена ошибка:

В этом случае базу данных необходимо обновить до актуальной версии.

В окне Подготовка к миграции отображается список некорректных данных для миграции. Для их исправления необходимо нажать на кнопку Продолжить.

По завершению подготовки к миграции на экран будет выведен протокол.

Установка Центра обновления.

Необходимо выполнить установку утилиты Центр обновления, согласно инструкции.

Миграция данных.

Миграция данных выполняется через Центр обновления.

На исходную базу MSSQL необходимо установить пакет программ для миграции.Для этого в утилите необходимо перейти во вкладку "Обновление"(пиктограмма в виде стрелки вниз), внести параметры подключения к СУБД где находится исходная БД и нажать на кнопку "Подключиться"

Далее перейти во вкладку "Составление задач", выбрать операцию "Установка обновлений", выделить исходную БД, далее перейти в вложенную вкладку "Дополнения" нужно отобрать пункт "Пакет программ для миграции" и нажать на кнопку "Выполнить".

После установки пакетов нажать на кнопку "Ок" у утилиты

Далее появится сообщение [image] , в котором нужно нажать на кнопку "Да". После этого необходимо отключиться от целевой БД, нажав на кнопку "Отключиться" - открыв Параметры подключения утилиты.

Далее необходимо перейти во вкладку "Миграция", внести параметры подключения к СУБД, где находится исходная БД, и нажать на кнопку "Подключиться".

На вкладке Параметры миграции необходимо выбрать исходную БД, после чего появится сообщение о необходимости получения лицензионного ключа

Необходимо нажать на кнопку "ОК", после чего в появившемся окне "Настройки лицензионного ключа" скопировать хэш и заказать ключ через портал. Полученный ключ необходимо ввести в соответствующее поле и нажать на кнопку "Применить"

Если постмиграционный пакет для выбранной БД отсутствует или версия исходной БД для миграции отличается от версии пакета либо в поле поставщик СУБД выбран поставщик отличный от Postgre, будет выведено сообщение об ошибке:

Если база данных соответствует нужной версии, необходимо настроить параметры базы-приемника и авторизации. Поле Имя пакета будет заполнено автоматически.

Далее необходимо нажать кнопку Выполнить.

Миграция проходит в два этапа.

На первом этапе переносятся все таблицы и данные.

На втором этапе происходит обновление платформы и создание необходимых функций комплекса .

По окончанию процесса выполнения база данных готова к использованию.

Процесс выполнения будет отображен в окне Выполнение задач.

После удачного выполнения миграции, статус изменится на "Выполнено" иначе появится возможность восстановить БД источника по нажатию кнопки "Восстановить"


6. Управление

Navigation: 7. Примеры работы >

6. Управление

 Return to chapter overview
1. Загрузить не активные контейнеры
2. Перетащить активные контейнеры в доступные области
3. Управление экземпляром контейнера
4. Управление сервером через терминал

Рис. 1. Управление сервером.